Start a new topic

i can't add a new language


I have a problem with amara.Whenever i click "add a new language'' nothing happens.

I would really appreciate any help.

Thanks in advance!

Thank you for reporting this, samer abdullah.

Please indicate the URL/s of the  Amara page/s where this is happening . and also the operating system and browser you use when this happens.

Thank you in advance

Claude Almansi


Thank you for answering.


I tried chrome ,firefox,and explorer.I am using windows 7

Thank you, Samer,

I had the same problem when I tried in the Greek interface, like you, and also from the basic URL

However, when I changed the interface to English,, I was able to start English subtitles.

I don't understand why and I'm curious to know. If you are curious too, I could generate a ticket from your topic and you'll get notifications. But if you'd rather just go on subtitling, I'll ask directly.

Please let me know.




I have the same problem here.  Wether I use Firefox or Chrome on Windows 7, I'm stuck at the choice  of language when I press on "Continue".  I haven't logged in for almost a year.  Is there something that has changed since?
I have tried with several videos hosted on Youtube, edited by my team : the California Academy of Science, still stuck. I have changed the interface language as suggested, all the same...

Any idea what might cause this? Is there specific software that I must purchase or update?

Thank you for your contribution, Cesslator. 

If you mean the video in, it has been added to the California Academy of Sciences team.

You should therefore ask one of the team admins. In fact, they can impose special settings on subtitling languages.



PS In case you have another query in future, please indicate the URL of the Amara video page: it is not always possible to deduce it from a screenshot.

Login or Signup to post a comment