Start a new topic

What happened to all the LINE BREAKS within subtitles? They're all gone now. Does it have to do with the upgrade?

I know there was a big upgrade recently where subtitles were lost, but also being restored. I haven't really seen any missing subtitles, but instead, I've noticed that all my subtitles are missing the line breaks that I put in (I originally used SHIFT-ENTER to put line breaks and it's been displaying perfectly on 2 lines until now)

So a line that looked like this originally:

There were 3 little pigs
who lived on a farm in Houston.

Now looks like this:

There were 3 little pigswho lived on a farm in Houston.

The line break between "pigs" and "who" is gone and the 2 lines are now squished together and displayed all on one line.

For example:

Will these be restored somehow from a backup?



I tried going back to an old video which lost its line breaks and tried manually adding them back in (with SHIFT-ENTER).

I found that if I just added the line breaks back in and pressed save, none of the changes were saved and was as if I hadn't edited it at all, no new revision was created and the subtitles still on a single line.

It only saved a new revision if I changed or added new letters into the subtitle and pressed save. And in that case, line breaks were recognized.

So does that mean that Amara doesn't recognize just adding line breaks as a change to the subtitle and cause for a new revision to be created? I'm pretty sure that I've just added a line break or two before and it saved properly, not sure why it doesn't now.

1 person has this problem

Thanks for the detailed description, CC.

Just after the upgrade,  I looked at the English subtitles of "David Hockney: Photoshop is boring", i.e. to what is now their Revision 4 and I also found banged-together words there:

0:04 – 0:09 and in a way, chemical photography is nowended.
0:14 – 0:18 Now, nobody thought chemical photography wouldend.
0:26 – 0:33 Kodak stopped making fixative about eightyears ago, I think.

But I hadn't connected them with disappeared line breaks, because I seldom use line breaks, except in poetry and song lyrics.

However, in this case, I had made revision 4 by downloading the unsynced revision 3 as TXT, adding it to a copy of the video privately uploaded to YT, letting the YT software do the syncing into subtitles, then reuploading the YT-synced subtitles as revision 4.

And these YT-synced subtitles did have line breaks between the words that appeared banged together after the upgrade.

There must be heaps of other subtitles presenting the same issue - beyond  the ones you and I mentioned. Among those, all the English subtitles Darren Bridenbeck (Amara)  added by upload to the videos of teams where he is owner or admin. In fact, the issue obtains in all the English subtitles I checked that had been added by him to videos of the (private) Independent Film - Workgroup team. So let's hope this will incite Amara staff to address it. [July 3, 2013]

Updates, July 4, 2013:


July 14, 2013. The removed line breaks issue is still unsolved and the hope raised by nuncho's message that the Amara team might start again reading, replying and acting upon issues raised in this forum has been proved unwarranted.


July 25, 2013:

The first lines of  now read

Sabrina Cristoni edited Portuguese subtitles for AfterPornEnds 1080p 178 16x9 2398 e... 1 day, 16 hours ago

Darren Bridenbeck (Amara) edited English subtitles for VioletTendencies 1080p 178 16x9 239... 6 months, 3 weeks ago

Víctor San Martín Morales edited Spanish subtitles for AfterPornEnds 1080p 178 16x9 2398 e... 3 months, 2 weeks ago

teddy fres edited Spanish subtitles for AfterPornEnds 1080p 178 16x9 2398 e...

3 months, 3 weeks ago teddy fres edited Spanish subtitles for AfterPornEnds 1080p 178 16x9 2398 e... 4 months, 1 week ago


July 26, 2013: the issue is also and still present in the Spanish Subtitles  created 06/06/2013 by Yatzil Gomez of Testimonio viuda de Eleuterio García Rojas, Celendín .

 July 28, 2013: the issue is also present in the English subtitles  of Capitalism and Socialism: Crash Course World History #33 , which Anne H. mentioned today in the Subtitles missing spaces?  topic.

And Capitalism and Socialism: Crash Course World History #33 presents another glitch possibly caused by the June 29, 2013 upgrade: the video language is not assigned. See Video language selection deleted after (by?) the June 29, 2013 upgrade .

After the update we ran a script to fix the missing line breaks - however there are some cases where it may need to be run again.   If we could get a clear list of the videos still needing line break correction in this post - we can get them fixed up.



1 person likes this
Thank you, Janet. The missing linebreaks issue is still present in:

If more come up, I'll add them here.


Login or Signup to post a comment